400-618-8070

10alt" />
新闻资讯
News
企业新闻
在XR系统实施EIGRP和RIP协议-实施静态路由《思科运营商CCIE认证实现指南》
发布时间:2018-05-30   浏览次数:   分享:

在XR系统实施EIGRP和RIP协议-实施静态路由

-本文来自乾颐堂CCIE认证培训讲师军哥《思科运营商CCIE认证实现指南》


2部分 核心路由协议

核心路由协议是思科公布的CCIE Service Provider Lab Exam Version 4.0(运行商CCIE实验考试v4.0)大纲部分的第1部分Core Routing中的重要内容

本书的部分重点在于学习和实施IOS XEIOS XR设备上的核心路由协议,这些路由协议的IPv4架构下通常包括OSPFIS-ISEIGRP以及BGP协议,IPv6协议栈下包括OSPFv3IS-IS for IPv6EIGRP for IPv6BGPIPv6单播的支持。

在今后的实施中,如无特殊说明,IP编址规则如下:R3连接R4的接口地址为13.1.1.3/24(xy.1.1.x,其中xy为设备编号),环回接口地址为33.1.1.1/32xx.1.1.1/32)。IPv6的编址规律为:R3连接R4的接口地址为2034::3/64,环回接口为2033::3/128xx.1.1.1/128.

2 XR系统实施EIGRPRIP协议

2.1 实施静态路由

静态路由在现网中应用广泛,在运营商网络也是很常用的一种用于临时调整路由或者实施默认路由的方式。它通常用于小范围的临时调整。在XR系统上也是比较重要的应用,尤其是在后期我们要学习的重要的在XR上实施AS之间的MPLS VPN网络必须实施静态路由。其管理距离和传统IOS相同,都为1.

我们在拓扑中2-1中来实施静态路由,用以满足如下需求XR1R3的环回接口的IPv4地址通过静态通信,XR2R3的环回接口的IPv6地址通过静态通信

                                               

2-1 2章逻辑拓扑

2.1.1 IPv4的静态路由实施

如果没有特殊情况,在一个多点接入的以太网络,实施静态路由请在目的前缀后附加出接口+下一跳,不要只附加出接口(域间MPLS VPN除外)。否则路由器会认为去往目标地址的网络是直连网络,那么它会请求直连地址的ARP,如果对端关闭了代理ARP则数据无法通信;另外在ARP报文中广播会占用大量带宽,降低网络的性能。

RP/0/0/CPU0:PE-XR1(config-if)# ipv4 address 13.1.1.1 255.255.255.0

RP/0/0/CPU0:PE-XR1(config-if)#exi

RP/0/0/CPU0:PE-XR1(config)#interface Loopback0

RP/0/0/CPU0:PE-XR1(config-if)# ipv4 address 11.1.1.1 255.255.255.255

RP/0/0/CPU0:PE-XR1(config-if)#exit

RP/0/0/CPU0:PE-XR1(config)#router static //启动静态路由进程

RP/0/0/CPU0:PE-XR1(config-static)#address-family ipv4 unicast

RP/0/0/CPU0:PE-XR1(config-static-afi)#33.1.1.1/32 gigabitEthernet 0/0/0/1 13.1.1.1.3 //IPv4地址族下实施静态路由

RR-R3(config)#interface Ethernet0/2

RR-R3(config-if)# ip address 13.1.1.3 255.255.255.0

RR-R3(config-if)#exi

RR-R3(config)#interface loopback 0

RR-R3(config-if)#ip add 33.1.1.1 255.255.255.255

RR-R3(config-if)#ipv6 address 2033::3/128

RR-R3(config)#ip route 11.1.1.1 255.255.255.255 ethernet 0/2 13.1.1.1

验证

XR1

sh route static //验证XR设备的静态路由

Sat Sep 17 14:07:43.868 UTC

 

S    2.2.2.2/32 is directly connected, 14:59:15, Null0

S    33.1.1.1/32 [1/0] via 13.1.1.3, 00:00:51, GigabitEthernet0/0/0/1

sh ip route static

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP

       a - application route

       + - replicated route, % - next hop override

 

Gateway of last resort is 35.1.1.5 to network 0.0.0.0

 

      11.0.0.0/32 is subnetted, 1 subnets

S        11.1.1.1 [1/0] via 13.1.1.1, Ethernet0/2

RR-R3#ping 11.1.1.1 source loopback 0 //数据报文可以正常的传送

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 11.1.1.1, timeout is 2 seconds:

Packet sent with a source address of 33.1.1.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/9 ms

实验完毕。

2.1.2 IPv6的静态路由实施

IPv6的静态路由和IPv4的静态路由并没有太多区别,其作用也相同。我们在XR2R3上实施IPv6的静态路由。

RP/0/0/CPU0:R2(config)#int gigabitEthernet 0/0/0/0

RP/0/0/CPU0:R2(config-if)#ipv6 address 2023::2/64

RP/0/0/CPU0:R2(config-if)#exi

RP/0/0/CPU0:R2(config)#router static

RP/0/0/CPU0:R2(config-static)#address-family ipv6 unicast

RP/0/0/CPU0:R2(config-static-afi)#2033::3/128 gigabitEthernet 0/0/0/0 2023::

RR-R3(config)#int e0/1

RR-R3(config-if)#ipv6 address 2023::3/64

RR-R3(config-if)#exi

RR-R3(config)#ipv6 route 2022::2/128 ethernet 0/1 2023::2

验证IPv6的静态路由和数据报文传送

RP/0/0/CPU0:R2#show route ipv6 static                 

Sat Sep 17 14:24:07.371 UTC

 

S    2033::3/128

      [1/0] via 2023::3, 00:00:03, GigabitEthernet0/0/0/0

RR-R3#show ipv6 route static

IPv6 Routing Table - default - 12 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, ls - LISP site

       ld - LISP dyn-EID, a - Application

S   2022::2/128 [1/0]

     via 2023::2, Ethernet0/1

RP/0/0/CPU0:R2#ping 2033::3 source 2022::2

Sat Sep 17 14:25:07.787 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2033::3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/22/69 ms

数据报文可以通过IPv6静态路由发送。实验完毕

2.2 实施EIGRP协议

在运营商内部几乎不会使用EIGRP协议作为IGP来使用,原因很简单,EIGRP是思科公司私有的协议(在将来可能会走向公有化),这意味着它不可能大规模部署,另外它无法支持MPLS流量工程也是原因之一。但在运营商的客户网络接入运营商的时候还是非常有可能使用的,所以我们需要熟悉该协议的实施。

2.2.1 EIGRP基本知识

EIGRP(Enhanced Interior Gateway Routing Protocol)增强内部网关路由协议。不同于传统的距离矢量协议,EIGRP有着很快的收敛时间,而且不用发送定期的路由更新;也不像链路状态协议,EIGRP并不知道整个网络是什么样的,它只能靠邻居公布的信息。EIGRP使用与IGRP相同的路由算法DUAL(扩散更新算法)DUAL机制是EIGRP的核心,通过它来实现无环路径。内部EIGRP管理距离为90,外部EIGRP管理距离为170,支持等价和非等价负载均衡。IP数据包中,EIGRP的协议字段为88

EIGRP的优点包括:

100%无环:如果整个网络包含在一个自制系统中,EIGRP使用DUAL能保证一张100%无环路由转发表;

快速收敛:EIGRP使用DUAL(),通过备份路由而实现,当S不可用时,快速切换到FS上从而达到快速收敛的目的;

使用多播、单播:使用组播(224.0.0.10)或单播进行路由更新,节省链路带宽;

度量值:EIGRP使用带宽(bandwidth)、延迟(delay)、可靠性(reliability)、负载(loading)、最大传输单元(MTU)这五个值来计算度量,默认情况下只有带宽和延迟起作用。计算公式为——EIGRP度量=[(10^7/路径上的最小带宽)+(所有延迟之和)]×256

可行距离(Feasible Distance):到达一个目的地的最小度量值。

通告距离(Advertise Distance):相邻路由器所通告的它自己到达某个目的地的最小度量值。

可行条件(Feasible Condition):通告距离(AD)小于可行距离的条件即AD

EIGRP 后继(Successor):一个直接连接的邻居路由器,它满足FC,通过它具有到达目的地的最小度量值的路由器。后继路由器被用作下一跳来将报文转发到目的地。

可行后继(Feasible Successor):一个邻居路由器,它满足FC,具有到目的地第二低度量值的路由器。当主路由S不可用时,FS被用来替代主路由,因而被保存在拓扑表中,当做备用路由。

活跃状态/主动路由(active state):是一种正在搜索FS的状态,当路由器丢失了S,并且没有FS可用时,该路由进入活跃状态,是一条不可用的路由。当一条路由处于活跃状态时,路由器向所有邻居发送查询来寻找另外一条到达该目的地的路由。

被动状态/被动路由(passive state):是一种目前有正确的路由到达目的地的状态,当路由器失去了S而有一个FS时,或者再找到一个S时,该路由进入被动状态,是一条可用路由。

EIGRP几乎不需要修改就能够支持IPv4协议栈和IPv6协议栈。

2.2.2 实施IPv4EIGRP

在运营商的网络中,IPv4仍然占据着主导地址,可以也是如此。运营商可以提供MPLS3VPN,在PE(运营商边界)设备上需要和客户之间建立动态路由协议的邻居,如果客户采用EIGRP,此时运营商也需要使用EIGRP,所以让我们来熟悉一下EIGRPXR上的实施。我们在图2-2上来实施EIGRP协议.在实施之前请去掉之前的IPv4IPv6的静态路由

2-2 EIGRP逻辑拓扑

XR1

router eigrp 90

 address-family ipv4 //初始化EIGRPIPv4单播路由的支持

  no auto-summary

  interface Loopback0 //该接口运行EIGRP,并把该接口所在的网络通告到EIGRP拓扑中用于更新和计算。

   passive-interface //把该接口使能被动接口,那么该接口不再尝试发送Hello报文去构建邻居

  !

  interface GigabitEthernet0/0/0/0

  !

  interface GigabitEthernet0/0/0/1

XR2

router eigrp 90

 address-family ipv4

  interface Loopback0

  !

  interface GigabitEthernet0/0/0/0

  !

  interface GigabitEthernet0/0/0/2

R3

router eigrp 90

 network 13.1.1.0 0.0.0.255

 network 23.1.1.0 0.0.0.255

 network 33.1.1.1 0.0.0.0

验证EIGRP邻居

RP/0/0/CPU0:R2#show eigrp ipv4 neighbors

Sat Sep 17 17:41:40.249 UTC

 

IPv4-EIGRP Neighbors for AS(90) VRF default

 

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   12.1.1.1                Gi0/0/0/2         13 00:01:50   17   200  0  6

0   23.1.1.3                Gi0/0/0/0         14 00:01:51 1276  5000  0  9

RP/0/0/CPU0:PE-XR1#show eigrp 90 neighbors

Sat Sep 17 17:40:38.833 UTC

 

IPv4-EIGRP Neighbors for AS(90) VRF default

 

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   12.1.1.2                Gi0/0/0/0         14 00:01:39   19   200  0  5

0   13.1.1.3                Gi0/0/0/1         14 00:02:08 1032  5000  0  10

 

验证运行EIGRP的接口

RP/0/0/CPU0:PE-XR1#show eigrp ipv4 interfaces

Sat Sep 17 17:41:19.860 UTC

 

IPv4-EIGRP Interfaces for AS(90)

 

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending

Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes

Gi0/0/0/0          1        0/0        19       0/10          72           0

Gi0/0/0/1          1        0/0      1032       0/10        5156           0

Lo0                0        0/0         0     640/640          0           0

验证通过EIGRP的路由

RP/0/0/CPU0:PE-XR1#show route eigrp

Sat Sep 17 17:41:44.329 UTC

 

D    22.1.1.1/32 [90/10752] via 12.1.1.2, 00:02:44, GigabitEthernet0/0/0/0

D    23.1.1.0/24 [90/15360] via 12.1.1.2, 00:02:44, GigabitEthernet0/0/0/0

D    33.1.1.1/32 [90/2570240] via 13.1.1.3, 00:02:58, GigabitEthernet0/0/0/1

验证通过EIGRP路由做出决策之后的数据转发

RP/0/0/CPU0:PE-XR1#ping 33.1.1.1 source 11.1.1.1

Sat Sep 17 17:42:41.665 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 33.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/12/59 ms

RP/0/0/CPU0:PE-XR1#ping 22.1.1.1 source 11.1.1.1

Sat Sep 17 17:42:46.594 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 22.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

 

2.2.3 实施EIGRPIPv6的支持

2-3 EIGRPv6实施拓扑图

IPv6路由也可以通过Eigrp去通告和学习,在本小节中,我们在图2-3中去实施Eigrpv6去承载IPv6的路由。请读者自行配置IPv6地址,此处仅给出XR1的基础配置。

hostname XR1

interface Loopback0

 ipv6 address 2011::1/128

!

interface GigabitEthernet0/0/0/1

 ipv6 address 2013::1/64

 no shutdown

!

interface GigabitEthernet0/0/0/2

 ipv6 address 2012::1/64

 no shutdown

在整个拓扑上实施EIGRPv6协议

R4-MS(config)#ipv6 unicast-routing //启动IPv6路由功能,在经典IOS上默认没有开启IPv6路由功能,而IOS XR默认开启

R4-MS(config)#ipv6 router eigrp 90 //启动EIGRPv6,在经典IOSEIGRPv6进程默认关闭,正如下面一条命令,手工开启进程。

R4-MS(config-rtr)#no shutdown

R4-MS(config-rtr)#int lo0

R4-MS(config-if)#ipv6 eigrp ?

 <1-65535>  AS number

 

R4-MS(config-if)#ipv6 eigrp 90 ?

 

 

R4-MS(config-if)#ipv6 eigrp 90 //在接口上使能EIGRPv6,同时该路由也会被通告到EIGRP

R4-MS(config-if)#int e1/1

R4-MS(config-if)#ipv6 eigrp 90

R4-MS(config)#int e0/2

R4-MS(config-if)#ipv6 eigrp 90

!

R3-SITE1(config)#ipv6 unicast-routing

R3-SITE1(config)#ipv6 router eigrp 90

R3-SITE1(config-rtr)#no shutdown

R3-SITE1(config-rtr)#exi

R3-SITE1(config)#int

R3-SITE1(config)#interface lo0

R3-SITE1(config-if)#ipv6 address 2033::3/128

R3-SITE1(config-if)#ipv6 eigrp 90 ?

 

 

R3-SITE1(config-if)#ipv6 eigrp 90

R3-SITE1(config-if)#int e1/0

R3-SITE1(config-if)#ipv6 address 2034::3/64

R3-SITE1(config-if)#ipv6 eigrp 90         

*Nov 23 14:26:35.785: %DUAL-5-NBRCHANGE: EIGRP-IPv6 90: Neighbor FE80::A8BB:CCFF:FE00:211 (Ethernet1/0) is up: new adjacency

R3-SITE1(config-if)#int e0/2

R3-SITE1(config-if)#no shu

R3-SITE1(config-if)#ipv6 address 2013::3/64

R3-SITE1(config-if)#ipv6 eigrp 90

XR1:

router eigrp 90 //IOS XR默认支持IPv6路由功能,可以直接启动EIGRPv6进程

 address-family ipv6 //初始化IPv6进程

  interface Loopback0 //配置接口,意味着该接口运行EIGRPv6

  !

  interface GigabitEthernet0/0/0/0

  !

  interface GigabitEthernet0/0/0/1

XR2:

router eigrp 90

 address-family ipv6

  interface Loopback0

  !

  interface GigabitEthernet0/0/0/1

  !

  interface GigabitEthernet0/0/0/2

验证EIGRPv6的邻居以及路由状况

RP/0/0/CPU0:XR1#show eigrp ipv6 neighbors //查看EIGRPv6的邻居,读者可以看到EIGRP也可其他IPv6IGP协议一样,通过链路本地地址就可以发现和建立邻居关系

Wed Nov 23 14:31:24.806 UTC

 

IPv6-EIGRP Neighbors for AS(90) VRF default

 

H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   Link Local Address:     Gi0/0/0/1         10 00:05:39 1276  5000  0  9

    fe80::a8bb:ccff:fe00:320

0   Link Local Address:     Gi0/0/0/0         14 00:07:38   18   200  0  9

    fe80::5200:ff:fe0a:3

RP/0/0/CPU0:XR1#show route ipv6 eigrp //查看通过EIGRP得到的IPv6路由

Wed Nov 23 14:31:37.225 UTC

 

D    2022::2/128

      [90/10752] via fe80::5200:ff:fe0a:3, 00:07:48, GigabitEthernet0/0/0/0

D    2024::/64

      [90/15360] via fe80::5200:ff:fe0a:3, 00:07:48, GigabitEthernet0/0/0/0

D    2033::3/128

      [90/2570240] via fe80::a8bb:ccff:fe00:320, 00:05:49, GigabitEthernet0/0/0/1

D    2034::/64

      [90/1029120] via fe80::a8bb:ccff:fe00:320, 00:05:49, GigabitEthernet0/0/0/1

D    2044::4/128

      [90/2575360] via fe80::5200:ff:fe0a:3, 00:07:48, GigabitEthernet0/0/0/0

测试IPv6数据包的发送,正常达到目的地

RP/0/0/CPU0:XR1#ping 2044::4 source 2011::1

Wed Nov 23 14:32:57.850 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2044::4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 19/47/89 ms

RP/0/0/CPU0:XR1#ping 2033::3 source 2011::1

Wed Nov 23 14:33:06.219 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2033::3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

RP/0/0/CPU0:XR1#ping 2022::2 source 2011::1

Wed Nov 23 14:33:11.529 UTC

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2022::2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 9/9/9 ms

基本的EIGRP实施完毕

接下来我们来实施EIGRPv6的便宜列表,即增加某条路由的度量值,我们选取了2022::2/128的路由,请读者注意观察之前的该路由的度量值为10752

route-policy Offset //启动RPL这个在XR上非常实用的工具

  if destination in (2022::2/128) then

    add eigrp-metric 1000000 1 255 1 1500 //如果匹配到路哟2022::2/128则增加(注意是增加)eigrp的度量值参数,带宽增加了1000000,后面的参与也增加

  endif

pass //不要忘记允许其他路由被收取。

end-policy

!

router eigrp 90

 address-family ipv6

  route-policy Offset in //在入方向调用RPL

 

实施完毕之后来验证新的路由表

RP/0/0/CPU0:XR1# show route ipv6 eigrp

Wed Nov 23 14:45:55.507 UTC

 

D    2022::2/128

      [90/12800] via fe80::5200:ff:fe0a:3, 00:05:54, GigabitEthernet0/0/0/0 //该路由

D    2024::/64

      [90/15360] via fe80::5200:ff:fe0a:3, 00:05:01, GigabitEthernet0/0/0/0

D    2033::3/128

      [90/2570240] via fe80::a8bb:ccff:fe00:320, 00:05:01, GigabitEthernet0/0/0/1

D    2034::/64

      [90/1029120] via fe80::a8bb:ccff:fe00:320, 00:05:01, GigabitEthernet0/0/0/1

D    2044::4/128

      [90/2575360] via fe80::5200:ff:fe0a:3, 00:05:01, GigabitEthernet0/0/0/0

EIGRPv6还要其他的特性,在此不再一一赘述。


-本文来自乾颐堂CCIE认证培训讲师军哥《思科运营商CCIE认证实现指南》


《思科运营商CCIE认证实现指南》在JD、TB有售,可自行购买,

技术问题可加群:346968792,安德老师会在线答疑

乾颐堂客服热线:400-618-8070

乾颐堂官网:www.qytang.com

乾颐堂网络实验室 我们为您想的更多

 ©2013-2014  乾颐堂网络工程师培训  版权所有  京ICP备14044984号-2 

 中国权威 Cisco (思科) CCNA CCNP CCIE 认证培训 企业定制培训

 咨询报名电话:400-618-8070   

CCNA论坛